accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ray Pfaff <ray.pf...@apx-labs.com>
Subject Re: Communication issue between zookeeper and accumulo
Date Tue, 06 Aug 2013 16:19:25 GMT
I'm not sure if I can provide those due to the contract I'm working.  I really don't want to
diverge this conversation from the original question I'm asking (which is a problem even running
one tablet server per machine) but are you saying that setting tserver.port.search = true
shouldn't be done?  I found this to be an undocumented way of running more than one tablet
server per system.  I'm still not convinced that this leads to stability issues on tablet
servers.  As I said, it's undocumented.

From: Eric Newton <eric.newton@gmail.com<mailto:eric.newton@gmail.com>>
Reply-To: "user@accumulo.apache.org<mailto:user@accumulo.apache.org>" <user@accumulo.apache.org<mailto:user@accumulo.apache.org>>
Date: Tuesday, August 6, 2013 11:12 AM
To: "user@accumulo.apache.org<mailto:user@accumulo.apache.org>" <user@accumulo.apache.org<mailto:user@accumulo.apache.org>>
Subject: Re: Communication issue between zookeeper and accumulo

Interesting.  You could not get similar performance improvements by increasing the size of
the JVM, the number of threads, or the number of tablets per server?

If you have details about what configurations you've tried and the performance numbers you
found, please open a ticket.  This would indicate that we have some unnecessary bottleneck
in the tserver.

-Eric



On Tue, Aug 6, 2013 at 11:00 AM, Ray Pfaff <ray.pfaff@apx-labs.com<mailto:ray.pfaff@apx-labs.com>>
wrote:
Because we found this to be the optimal number of tablet servers in our testing.  It performs
better than one per machine.  I'm not convinced that the stability issues make it worthwhile.
Doesn't affect my problem anyway.  I get this error whether I run one or four tablet servers.
 Running four just makes it a bigger issue to get back up after failure.

From: Eric Newton <eric.newton@gmail.com<mailto:eric.newton@gmail.com>>
Reply-To: "user@accumulo.apache.org<mailto:user@accumulo.apache.org>" <user@accumulo.apache.org<mailto:user@accumulo.apache.org>>
Date: Tuesday, August 6, 2013 10:56 AM
To: "user@accumulo.apache.org<mailto:user@accumulo.apache.org>" <user@accumulo.apache.org<mailto:user@accumulo.apache.org>>
Subject: Re: Communication issue between zookeeper and accumulo


I'm running 4 tservers per machine dedicated to the tablet servers

Why?



Mime
View raw message