accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <josh.el...@gmail.com>
Subject Re: Setting dev environment in Eclipse
Date Thu, 01 Aug 2013 02:23:54 GMT
Ravi,

Looks like we need to get SNAPSHOTs published there? That's a task for us.

In the meantime to get yourself going, you could `mvn install 
-DskipTests` to get a 1.5.1-SNAPSHOT into your local repo, and then 
rerun the `mvn eclipse:clean eclipse:eclipse`. A `mvn package` doesn't 
place anything into your repository which is what you're seeing.

Potentially, not sure how the eclipse plugin works, you might be able to 
make things work with a `mvn package eclipse:clean eclipse:eclipse`. Not 
sure if the reactor would pick up the local artifacts you just built.

- Josh

On 07/31/2013 10:14 PM, Ravi Mutyala wrote:
> Hi,
>
> I am trying to setup a dev environment in eclipse. I started with 'mvn eclipse:clean
eclipse:eclipse'. (using 1.5.1-SNAPSHOT) and I got the following error. This is after a fresh
local build with 'mvn package -P assemble'.
>
> Any thoughts of how to fix this?
>
> [ERROR] Failed to execute goal on project accumulo-core: Could not resolve dependencies
for project org.apache.accumulo:accumulo-core:jar:1.5.1-SNAPSHOT: The following artifacts
could not be resolved: org.apache.accumulo:accumulo-fate:jar:1.5.1-SNAPSHOT, org.apache.accumulo:accumulo-start:jar:1.5.1-SNAPSHOT,
org.apache.accumulo:accumulo-trace:jar:1.5.1-SNAPSHOT: Failure to find org.apache.accumulo:accumulo-fate:jar:1.5.1-SNAPSHOT
in http://repository.apache.org/snapshots was cached in the local repository, resolution will
not be reattempted until the update interval of apache.snapshots has elapsed or updates are
forced -> [Help 1]
>
> Thanks.


Mime
View raw message