accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ott, Charles H." <CHARLES.H....@saic.com>
Subject RE: Trying to add tablet servers to accumulo 1.4 cluster
Date Thu, 23 May 2013 19:50:55 GMT
My Accumulo-site zookeeper location is a DNS entry that resolves the IP
where zookeeper is installed.  I can ping the server using the server
name as well.

 

 

 

From: user-return-2587-CHARLES.H.OTT=saic.com@accumulo.apache.org
[mailto:user-return-2587-CHARLES.H.OTT=saic.com@accumulo.apache.org] On
Behalf Of John Vines
Sent: Thursday, May 23, 2013 3:39 PM
To: user@accumulo.apache.org
Subject: Re: Trying to add tablet servers to accumulo 1.4 cluster

 

In your accumulo-site, are you defining the zookeeper location as
localhost or a defined IP? Is that IP Accessible?

 

If you need to change it, I will preface this with you need to bring
down your existing cluster before you change the file, as then you will
get an error with the servers talking to one another.

 

On Thu, May 23, 2013 at 3:37 PM, Ott, Charles H.
<CHARLES.H.OTT@saic.com> wrote:


        I setup Accumulo 1.4.3 with a single hdfs data node and tablet
server.  Added a bit of data to it and once my additional hardware
resources were free'd up I am now trying to add 3 additional tablet
servers.  I already setup 3 hdfs datanodes, so I wanted to just run the
tserver processes on the same 3 servers:

Node1, Node2, Node3


I keep seeing this error with one or two nodes:

Uncaught exception in TabletServer.main, exiting
        java.lang.RuntimeException: java.lang.RuntimeException: Too many
retries, exiting.
                at
org.apache.accumulo.server.tabletserver.TabletServer.announceExistence(T
abletServer.java:2684)
                at
org.apache.accumulo.server.tabletserver.TabletServer.run(TabletServer.ja
va:2703)
                at
org.apache.accumulo.server.tabletserver.TabletServer.main(TabletServer.j
ava:3168)
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
Method)
                at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.jav
a:39)
                at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessor
Impl.java:25)
                at java.lang.reflect.Method.invoke(Method.java:597)
                at org.apache.accumulo.start.Main$1.run(Main.java:89)
                at java.lang.Thread.run(Thread.java:662)
        Caused by: java.lang.RuntimeException: Too many retries,
exiting.
                at
org.apache.accumulo.server.tabletserver.TabletServer.announceExistence(T
abletServer.java:2681)
                ... 8 more


But not sure what it means.  I use the command ./stop-here.sh and then
./start-here.sh on the tablet server in question, but it still does the
same thing.  What is weird, is when I do stop-all/start-all from the
master, at most I have seen 2 tablets up, but I can't seem to get all 3
up at once.

 The only locations I know the tserver processes are writing data to is:
/var/lib/accumulo/walogs & /opt/accumulo/accumulo-current/logs

Not sure what I am doing wrong here.

 


Mime
View raw message