accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bell, Philip S CIV SPAWARSYSCEN-PACIFIC, 81320" <philip.b...@navy.mil>
Subject RE: FW: Deletes not commiting from custom java API but work in shell interface
Date Wed, 10 Apr 2013 22:20:25 GMT
We have not as of yet implemented any column visibility

When I first saw the problem, I created a separate table with some very generic test data
to try out the deletion, and nothing I do from the java API seems to actually cause a delete
to go through.  I assume if deletes work from the shell then the delete iterator is working
correctly, hence I'm out of ideas.

To add to the fun our test server is under maintenance for now but I can hopefully recreate
the problem in a VM soon.

I'll work on recreating the dummy data on my VM and see if I still see the issue, and also
post the dummy data here in case there's some strange thing I'm doing.

-----Original Message-----
From: John Vines [mailto:vines@apache.org] 
Sent: Wednesday, April 10, 2013 3:16 PM
To: user@accumulo.apache.org
Subject: RE: FW: Deletes not commiting from custom java API but work in shell interface

First, you don't need to flush then close. Close already flushes.

As for your problem, I have only 2 ideas- are you writing to the correct table?

And as a sanity check, make sure the authorization you construct equals the column visibility
you pull out. I wonder if information is getting lost in translation.

Sent from my phone, please pardon the typos and brevity.

Mime
View raw message