accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keith Turner <ke...@deenlo.com>
Subject Re: How Do I Add Split From Shell When Split Value Has Zero (\x00) Byte?
Date Thu, 11 Apr 2013 14:42:15 GMT
On Thu, Apr 11, 2013 at 10:38 AM, David Medinets
<david.medinets@gmail.com> wrote:
> I tried that addsplits with a zero byte and ran into something unexpected:
>
> createtable zerotest
> insert AA\x00BB cf cq value
> insert AA\x00CC cf cq value
> insert AA\x01CC cf cq value
> addsplits AA\0x00CC
> getsplits
> AACC <--- the zero byte is not displayed.
>
> This seems like a bug. If anyone can verify, I'll create a jira ticket.

that does seem like a bug.  Either the split was not added correctly,
or its not being displayed correctly.  Assuming it was added
correctly, the output of getsplits may not use the same code that
scans do to display unprintable bytes.

>
>
> On Thu, Apr 11, 2013 at 9:44 AM, Josh Elser <josh.elser@gmail.com> wrote:
>>
>> AFAIK you should be able to run "addsplits AAA\x00CCC" in the shell. Did
>> that not work?
>>
>>
>> On 4/11/13 9:24 AM, David Medinets wrote:
>>>
>>> I have rows that look like this when displayed through the shell:
>>>
>>> AAA\x00BBB
>>> AAA\x00BBB
>>> AAA\x00CCC
>>> AAA\x00CCC
>>>
>>> I would like to manually add a split for AAA\x00CCC. I know the shell has
>>> some restrictions on how some characters are handled so I thought I'd ask
>>> before trying.
>>
>>
>

Mime
View raw message