accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Terry Padgett <te...@hortonworks.com>
Subject Re: Accumulo JDK requirements
Date Fri, 12 Apr 2013 17:03:03 GMT
Charlie,

The dependency you have to be careful with is Hadoop. For example, OpenJDK
doesn't play well with all versions of Hadoop.  I attempted to use OpenJDK
1.6_24 with Hadoop 1.1.3 with tragic results. JMX exceptions were killing
the Namenode after a minute or so and the Datanodes would fail as well, but
with lower frequency. Accumulo had no issues per se, but without a
namespace, functionality was limited.

-Terry



On Fri, Apr 12, 2013 at 11:56 AM, Christopher <ctubbsii@apache.org> wrote:

> I've successfully built and run on Open JDK 6, Open JDK 7, and Oracle
> JDK 7 on my local development boxes.
>
> --
> Christopher L Tubbs II
> http://gravatar.com/ctubbsii
>
>
> On Wed, Apr 10, 2013 at 1:23 PM, Charles Inglese
> <charles.inglese@gmail.com> wrote:
> > Hello,
> >
> > I was wondering what JDK releases Accumulo 1.3 supports besides Oracle
> JDK =
> > 6?
> >
> > a) OpenJDK 6
> >
> > b) Oracle JDK 7
>

Mime
View raw message