accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jiun bookworm <thebookworm...@gmail.com>
Subject Re: Uncaught exception
Date Sat, 02 Mar 2013 19:00:51 GMT
thanks fo clarifying
i try 0.20 or another supported one.

On Sat, Mar 2, 2013 at 9:58 PM, John Vines <vines@apache.org> wrote:

> Sorry, that's a versioning thing with Hadoop. 0.23 is Hadoop 2, Hadoop
> 0.20 branch is Hadoop 1. My mistake for not being clear.
>
> Sent from my phone, please pardon the typos and brevity.
> On Mar 2, 2013 1:55 PM, "jiun bookworm" <thebookworm101@gmail.com> wrote:
>
>> iv  given hadoop 0.23.6 a go and when i try accumulo init this is the
>> error m getting:
>> and google doesnt seem to be any good.
>>
>>
>> java.lang.NoClassDefFoundError: org/apache/hadoop/io/WritableComparable
>>     at java.lang.ClassLoader.defineClass1(Native Method)
>>     at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
>>     at
>> java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
>>     at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
>>     at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
>>     at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
>>     at java.security.AccessController.doPrivileged(Native Method)
>>     at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
>>     at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
>>     at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
>>     at org.apache.accumulo.core.Constants.<clinit>(Constants.java:91)
>>     at
>> org.apache.accumulo.server.util.Initialize.<clinit>(Initialize.java:99)
>>     at java.lang.Class.forName0(Native Method)
>>     at java.lang.Class.forName(Class.java:264)
>>     at
>> org.apache.accumulo.start.classloader.AccumuloClassLoader.loadClass(AccumuloClassLoader.java:363)
>>     at
>> org.apache.accumulo.start.classloader.AccumuloClassLoader.loadClass(AccumuloClassLoader.java:370)
>>     at org.apache.accumulo.start.Main.main(Main.java:48)
>> Caused by: java.lang.ClassNotFoundException:
>> org.apache.hadoop.io.WritableComparable
>>     at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
>>     at java.security.AccessController.doPrivileged(Native Method)
>>     at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
>>     at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
>>     at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
>>     ... 17 more
>>
>>
>>
>>
>>
>>
>> On Sat, Mar 2, 2013 at 7:54 PM, John Vines <vines@apache.org> wrote:
>>
>>> Anything between hadoop 0.20.2 to 1.x should work.
>>>
>>> Sent from my phone, please pardon the typos and brevity.
>>> On Mar 2, 2013 11:51 AM, "jiun bookworm" <thebookworm101@gmail.com>
>>> wrote:
>>>
>>>> which is the latest version of hadoop that accumulo 1.4.2 works with?
>>>>
>>>> On Sat, Mar 2, 2013 at 7:49 PM, Billie Rinaldi <billie@apache.org>wrote:
>>>>
>>>>> On Sat, Mar 2, 2013 at 8:44 AM, John Vines <vines@apache.org> wrote:
>>>>>
>>>>>> Accumulo 1.4.x does not work against Hadoop 2.
>>>>>>
>>>>>
>>>>> John Vines makes a good point about 1.4 not working with Hadoop 2.
>>>>>
>>>>>
>>>>>> However, your error is different. Are you sure you have Hadoop_home
>>>>>> pointing at the right path. If you run bin/Accumulo classpath, you
should
>>>>>> get a listing which includes a smorgasbord of Hadoop classes.
>>>>>>
>>>>>> Sent from my phone, please pardon the typos and brevity.
>>>>>> On Mar 2, 2013 11:25 AM, "jiun bookworm" <thebookworm101@gmail.com>
>>>>>> wrote:
>>>>>>
>>>>>> This may be a noob issue, but some help would be appreciated.
>>>>>> im trying out accumulo, and i have setup zookeeper and hadoop in
a
>>>>>> single node setup
>>>>>> when i try to start accumulo this is what i see,
>>>>>>
>>>>>> accumulo-1.4.2]$ ./bin/accumulo init
>>>>>> Uncaught exception: org/apache/hadoop/io/WritableComparable
>>>>>> java.lang.NoClassDefFoundError:
>>>>>> org/apache/hadoop/io/WritableComparable
>>>>>>     at java.lang.ClassLoader.defineClass1(Native Method)
>>>>>>     at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
>>>>>>     at
>>>>>> java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
>>>>>>     at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
>>>>>>     at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
>>>>>>     at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
>>>>>>     at java.security.AccessController.doPrivileged(Native Method)
>>>>>>     at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
>>>>>>     at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
>>>>>>     at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
>>>>>>     at org.apache.accumulo.core.Constants.<clinit>(Constants.java:91)
>>>>>>     at
>>>>>> org.apache.accumulo.server.util.Initialize.<clinit>(Initialize.java:99)
>>>>>>     at java.lang.Class.forName0(Native Method)
>>>>>>     at java.lang.Class.forName(Class.java:264)
>>>>>>     at
>>>>>> org.apache.accumulo.start.classloader.AccumuloClassLoader.loadClass(AccumuloClassLoader.java:363)
>>>>>>     at
>>>>>> org.apache.accumulo.start.classloader.AccumuloClassLoader.loadClass(AccumuloClassLoader.java:370)
>>>>>>     at org.apache.accumulo.start.Main.main(Main.java:48)
>>>>>> Caused by: java.lang.ClassNotFoundException:
>>>>>> org.apache.hadoop.io.WritableComparable
>>>>>>     at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
>>>>>>     at java.security.AccessController.doPrivileged(Native Method)
>>>>>>     at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
>>>>>>     at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
>>>>>>     at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
>>>>>>     ... 17 more
>>>>>>
>>>>>> i have set the environement settings properly,
>>>>>>
>>>>>> test -z "$ACCUMULO_HOME"         && export
>>>>>> ACCUMULO_HOME=/home/me/eng/source/storage/accumulo-1.4.2
>>>>>> test -z "$JAVA_HOME"             && export
>>>>>> JAVA_HOME=/usr/lib/jvm/jre-1.6.0-openjdk.x86_64/
>>>>>> test -z "$HADOOP_HOME"           && export
>>>>>> HADOOP_HOME=/home/me/eng/source/storage/hadoop
>>>>>> test -z "$ZOOKEEPER_HOME"        && export
>>>>>> ZOOKEEPER_HOME=/home/me/eng/source/storage/zookeeper-3.4.5
>>>>>> test -z "$ACCUMULO_LOG_DIR"      && export
>>>>>> ACCUMULO_LOG_DIR=$ACCUMULO_HOME/logs
>>>>>>
>>>>>> what could be the issue, the hadoop im using is 2.0.3alpha.
>>>>>>
>>>>>>
>>>>>
>>>>
>>

Mime
View raw message