accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <>
Subject Re: Waiting for accumulo to be initialized
Date Wed, 27 Mar 2013 19:40:58 GMT
First off, I'm sorry about you losing data. I thought you recognized 
that this would be destructive on your data reading that link you sent 
out. I wasn't really advising you from a "saving data" standpoint.

Zookeeper crashing (or even `kill -9`ing) should have no effect on 
Hadoop. Did Hadoop come up correctly before you tried to restart 
Accumulo? Did you then do the `hadoop namenode -format` and expect to 
keep your data? If so, lesson learned?

On 3/27/13 3:18 PM, Aji Janis wrote:
> Eric and Josh thanks for all your feedback. We ended up _loosing all 
> our accumulo data_ because I had to reformat hadoop. Here is in a 
> nutshell what I did:
>  1. Stop accumulo
>  2. Stop hadoop
>  3. On hadoop master and all datanodes, from
>     (hdfs-site.xml) remove everything under the data folder
>  4. On hadoop master, from (hdfs-site.xml) remove
>     everything under the name folder
>  5. As hadoop user, execute.../hadoop/bin/hadoop namenode -format
>  6. As hadoop user, execute.../hadoop/bin/ ==> should
>     populate data/ and name/ dirs that was erased in steps 3, 4.
>  7. Initialized Accumulo - as accumulo user,  ../accumulo/bin/accumulo
>     init (I created a new instance)
>  8. Start accumulo
> I was wondering if anyone had suggestions or thoughts on how I could 
> have solved the original issue of accumulo waiting initialization 
> without loosing my accumulo data? Is it possible to do so?

View raw message