accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dlmar...@comcast.net
Subject Re: upgrading to CDH3u5
Date Thu, 07 Feb 2013 17:38:23 GMT
ACCUMULO-837 

----- Original Message -----
From: "John Vines" <vines@apache.org> 
To: user@accumulo.apache.org 
Sent: Thursday, February 7, 2013 12:23:48 PM 
Subject: Re: upgrading to CDH3u5 


I don't think that CDH3u5 requires a recompile, that's only the case for CDH4/hadoop 0.23/hadoop2.





On Thu, Feb 7, 2013 at 12:15 PM, Josh Elser < josh.elser@gmail.com > wrote: 



The upgrade *should* be relatively painless. 

The only thing to note is that you will need to recompile Accumulo against the correct CDH3
artifacts from >=CDH3u4. 

With Accumulo 1.5.0 this can be done by specifying -Dhadoop.version=0.20.2-cdh3u5 and -Dzookeeper.version=3.3.5-cdh3u5
when you `mvn package -Passemble`. With Accumulo 1.4.x, you'll have to update the dependencies
in the pom yourself. 

- Josh 




On 2/7/13 11:42 AM, Hider, Sandy wrote: 

<blockquote>



I am curious if anyone has upgraded their Accumulo clouds Hadoop version from 0.20.2  to
CDH3  which is based off of a version of 0.20.2.  Can you just replace one version with
another on an active cloud? 

  

Anyone tried this? 

  

Sandy 

  



</blockquote>


Mime
View raw message