accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Piety <timpi...@gmail.com>
Subject Re: Error BAD_CREDENTIALS
Date Tue, 08 Jan 2013 16:45:35 GMT
John,

Do I create the users via the shell as found in
http://accumulo.apache.org/1.4/user_manual/Accumulo_Shell.html#User_Administration?

Does the password have to be the same as the linux user demo's password. (I
will make it the same anyway, just wanted to know).

thanks,

Tim



On Tue, Jan 8, 2013 at 11:37 AM, John Vines <vines@apache.org> wrote:

> Accumulo keeps an internal store of users. When you initialize it, you
> only initialize the root user. You need to manually create additional ones
> via the shell or APIs. When you run the shell, you can pass it -u to
> specify the user to log in as, otherwise it defaults to the system user you
> are. Since you ran it as root, the namespaces corresponded so it worked
> out. Create a user for demo and use the correct password and it should all
> work out fine.
>
>
> On Tue, Jan 8, 2013 at 10:28 AM, Tim Piety <timpiety@gmail.com> wrote:
>
>> All,
>>
>> I am getting the following error when trying to connect from a Java
>> client:
>>
>> org.apache.accumulo.core.client.AccumuloSecurityException: Error
>> BAD_CREDENTIALS - Username or Password is Invalid
>>     at
>> org.apache.accumulo.core.client.impl.ServerClient.execute(ServerClient.java:73)
>>     at
>> org.apache.accumulo.core.client.impl.ConnectorImpl.<init>(ConnectorImpl.java:75)
>>     at
>> org.apache.accumulo.core.client.ZooKeeperInstance.getConnector(ZooKeeperInstance.java:218)
>>     at
>> org.apache.accumulo.core.client.ZooKeeperInstance.getConnector(ZooKeeperInstance.java:206)
>>     at
>> com.raytheon.accumulo.demo.AccumuloConnection.main(AccumuloConnection.java:19)
>> Caused by: ThriftSecurityException(user:demo, code:BAD_CREDENTIALS)
>>     at
>> org.apache.accumulo.core.client.impl.thrift.ClientService$authenticateUser_result.read(ClientService.java:7755)
>>     at
>> org.apache.accumulo.core.client.impl.thrift.ClientService$Client.recv_authenticateUser(ClientService.java:415)
>>
>> I get the same error if I run the accumulo shell as the demo user. If I
>> run the shell as root it all runs fine.
>>
>> do I need to change some permissions somewhere? I changed the hdfs
>> /accumulo to be 777 and all the files to be 777 as well, but that did not
>> change anything,
>>
>> I installed accumulo as root and initialized it as root.
>>
>> thanks in advance,
>>
>> Tim
>>
>>
>>
>>
>

Mime
View raw message