accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Mock <markus.m...@gmail.com>
Subject Problem with CloudStone4 benchmark in accumulo-1.4.1
Date Thu, 04 Oct 2012 18:04:59 GMT
Hi I am running into this problem with the CloudStone4  benchmark:

the mapreduce job it launches fails with:


java.lang.RuntimeException: java.lang.ClassNotFoundException:
org.apache.accumulo.core.clien\
t.mapreduce.AccumuloOutputFormat^M
        at org.apache.hadoop.conf.Configuration.getClass(Configuration.java:1004)^M
        at org.apache.hadoop.mapreduce.JobContext.getOutputFormatClass(JobContext.java:253)^\
M
        at org.apache.hadoop.mapred.Task.initialize(Task.java:509)^M
        at org.apache.hadoop.mapred.MapTask.run(MapTask.java:306)^M
        at org.apache.hadoop.mapred.Child$4.run(Child.java:266)^M
        at java.security.AccessController.doPrivileged(Native Method)^M
        at javax.security.auth.Subject.doAs(Subject.java:396)^M
        at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:12\
78)^M
        at org.apache.hadoop.mapred.Child.main(Child.java:260)^M
Caused by: java.lang.ClassNotFoundException:
org.apache.accumulo.core.client.mapreduce.Accum\
uloOutputFormat^M

I added some printout to the code to see how it invokes / launches that job:


Running TeraSortIngest
about to call runner.start
running:  ['/usr/lib/hadoop-0.20/accumulo/accumulo-1.4.1/bin/accumulo',
'org.apache.accumulo\
.examples.simple.mapreduce.TeraSortIngest', '-libjars',
'/usr/lib/hadoop-0.20/accumulo/accum\
ulo-1.4.1/lib/accumulo-core-1.4.1.jar,/usr/lib/hadoop-0.20/accumulo/accumulo-1.4.1/lib/libth\
rift-0.6.1.jar,/usr/lib/hadoop/accumulo/zookeeper-3.3.6/zookeeper-3.3.6.jar,/usr/lib/hadoop-\
0.20/accumulo/accumulo-1.4.1/lib/accumulo-start-1.4.1.jar',
'10000000000', '10', '10', '78',\
 '78', 'CloudIngestTest', 'markus-dist-test', '<IP edited out>',
'root', 'secret', '400']^M

Is this a known issue? What would be the workaround? It seems that the
tasks cannot find the
AccumuloOutputFormat class, however, it is on the -libjars line and I
also checked the task trackers
and the jar files seem to be in the distributed cache, so any idea why
the tasks don't find them?
Is that benchmark broken?

Thanks.

 -- Markus

Mime
View raw message