accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cardon, Tejay E" <tejay.e.car...@lmco.com>
Subject RE: EXTERNAL: Re: There are no tablet servers
Date Wed, 18 Jul 2012 19:31:56 GMT
William,
Thanks for the quick response.  I've checked mapred-site.xml and confirmed that it lists port
50030.  I've also hit 50030 with my browser and confirmed that it is up and running as the
JobTracker.  Would you expect an error with the log sorter to cause the tablet servers to
go down?  OR to never come up?

Tejay

From: William Slacum [mailto:wilhelm.von.cloud@accumulo.net]
Sent: Wednesday, July 18, 2012 12:23 PM
To: user@accumulo.apache.org
Subject: EXTERNAL: Re: There are no tablet servers

I'm sorry, 50030 is the http port for the JobTracker.
On Wed, Jul 18, 2012 at 11:21 AM, William Slacum <wilhelm.von.cloud@accumulo.net<mailto:wilhelm.von.cloud@accumulo.net>>
wrote:
50030 is the http port for HDFS. You probably want 9000 or 8020. Check your hdfs-site.xml

On Wed, Jul 18, 2012 at 11:15 AM, Cardon, Tejay E <tejay.e.cardon@lmco.com<mailto:tejay.e.cardon@lmco.com>>
wrote:
All,
I'm running into a strange challenge in my latest Accumulo installation.  I've developed some
chef recipes for deploying Accumulo, and have tested them on three clusters now with no problems.
 Using the same scripts, I recent did another deployment, but I'm having trouble on this one.

After installing Accumulo, updating the config files, and setting up passwordless ssh, I ran:
./accumulo init

Everything went normally with me setting the instanceID and password

Then I ran
./start-all.sh

Again, everything went smoothly with the following output:
bash-3.2$ ./start-all.sh
Starting tablet servers and loggers ....... done
Starting tablet server on de8-9a-8f-83-be-52
Starting logger on de8-9a-8f-83-be-52
Starting tablet server on d04-7d-7b-06-5e-48
Starting logger on de8-9a-8f-d3-3e-f8
Starting tablet server on d04-7d-7b-06-5d-f4
Starting logger on d04-7d-7b-06-5e-48
Starting logger on d04-7d-7b-06-5d-f4
Starting tablet server on de8-9a-8f-d3-3e-f8
18 12:48:50,970 [server.Accumulo] INFO : Attempting to talk to zookeeper
18 12:48:51,182 [server.Accumulo] INFO : Zookeeper connected and initialized, attemping to
talk to HDFS
18 12:48:51,568 [server.Accumulo] INFO : Connected to HDFS
Starting master on d04-7d-7b-06-5d-80
Starting garbage collector on d04-7d-7b-06-5e-ba
Starting monitor on d04-7d-7b-06-5e-ba
Starting tracer on d04-7d-7b-06-5d-80
Starting tracer on de8-9a-8f-d3-3e-f8
Starting tracer on d04-7d-7b-06-5e-48

I can also run a stop-all.sh with no complaints from the script.

However, if I try to start the Accumulo shell, I get

bash-3.2$ ./accumulo shell
Enter current password for 'hdfs'@'test4': ******
18 13:00:17,906 [impl.ServerClient] WARN : There are no tablet servers: check that zookeeper
and accumulo are running.

If I check the tablet server machines I find that they do not have any Accumulo processes
running, and the master does not have any tablet server logs.  (it does have the tracer logs,
however).

I've attached the log files here (without the empty ones).  There is an error trying to "clean
up old log sort" and a thrift error.
I'm at a loss for where to begin on the debugging for this.  Any thoughts would be greatly
appreciated.


18 12:48:54,100 [master.CoordinateRecoveryTask] ERROR: Error cleaning up old Log Sort jobsjava.io.IOException:
Call to /10.1.24.65:50030<http://10.1.24.65:50030> failed on local exception: java.io.EOFException

18 12:48:57,016 [impl.ServerClient] DEBUG: ClientService request failed null, retrying ...
org.apache.thrift.transport.TTransportException: Failed to connect to a server
                at org.apache.accumulo.core.client.impl.ThriftTransportPool.getAnyTransport(ThriftTransportPool.java:437)
                at org.apache.accumulo.core.client.impl.ServerClient.getConnection(ServerClient.java:145)
                at org.apache.accumulo.core.client.impl.ServerClient.getConnection(ServerClient.java:123)
                at org.apache.accumulo.core.client.impl.ServerClient.executeRaw(ServerClient.java:105)
                at org.apache.accumulo.core.client.impl.ServerClient.execute(ServerClient.java:71)
                at org.apache.accumulo.core.client.impl.ConnectorImpl.<init>(ConnectorImpl.java:75)
                at org.apache.accumulo.server.client.HdfsZooInstance.getConnector(HdfsZooInstance.java:145)
                at org.apache.accumulo.server.trace.TraceServer.<init>(TraceServer.java:152)
                at org.apache.accumulo.server.trace.TraceServer.main(TraceServer.java:222)
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                at java.lang.reflect.Method.invoke(Method.java:597)
                at org.apache.accumulo.start.Main$1.run(Main.java:89)
                at java.lang.Thread.run(Thread.java:662)





Mime
View raw message