accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <josh.el...@gmail.com>
Subject Re: EXTERNAL: Re: GLIBC error
Date Wed, 25 Jul 2012 00:01:39 GMT
`make clean && make`

The Makefile implicitly "install"s them for you. There's no additional 
target. The existing libraries in lib/native will be overwritten by 
virtue of the `cp` command the Makefile runs.

On 07/24/2012 05:00 PM, Cardon, Tejay E wrote:
> Thanks Keith, that probably would have bit me.  So the ideal would be
>
> make clean&  make&  make install
>
> Right??
>
> And would that work if the libs already exist, or do I need to delete them first?
>
> Tejay
>
> -----Original Message-----
> From: Keith Turner [mailto:keith@deenlo.com]
> Sent: Tuesday, July 24, 2012 3:55 PM
> To: user@accumulo.apache.org
> Subject: EXTERNAL: Re: GLIBC error
>
> On Tue, Jul 24, 2012 at 5:45 PM, John Vines<john.w.vines@ugov.gov>  wrote:
>> If you go to ACCUMULO_HOME/src/server/src/main/c++, run make install,
>> and it
> One thing to add, you may need to run make clean before running make install.  If the
intermediate files exists for some reason, the make install will do nothing.
>
>> should fix it right up. You may have to delete any existing native map
>> libraries in your lib directory. If you want to generate a tar.gz with
>> those libs, then run mvn -N assembly:single
>>
>> John
>>
>>
>> On Tue, Jul 24, 2012 at 5:22 PM, Cardon, Tejay E
>> <tejay.e.cardon@lmco.com>
>> wrote:
>>> I've been trying to run Accumulo on a new cluster, but I'm having trouble.
>>> I've done this many times before, but this time I'm getting an error
>>> on the tservers regarding glibc.  I think I've tracked it down to a
>>> version issue (the version of Glibc I've got installed isn't new
>>> enough, so it doesn't contain the right version of GLIBCXX).  I ran
>>> into this once before, and the solution was to build Accumulo from
>>> scratch with Maven.  However, I've tried that this time with no
>>> success.  If I download the *dist.tar.gz and do the build from there,
>>> it fails.  If I download the *-src.tar.gz and build from it, I can't
>>> seem to find the final packaged .tar.gz.  If I use the src.tar.gz,
>>> build it, and then just use the directory I built from, I get an error about
setting up log4j.  Any suggestions?
>>>
>>>
>>>
>>> Thanks
>>>
>>> Tejay
>>>
>>>
>>>
>>> Here's the error I get if I use the -dist.tar.gz This error is found
>>> in the .debug.log and .log files from the tserver.
>>>
>>>
>>>
>>> ERROR: Failed to load native map library
>>> /opt/accumulo-1.4.0/lib/native/map/libNativeMap-Linux-amd64-64.so
>>>
>>> java.lang.UnsatisfiedLinkError:
>>> /opt/accumulo-1.4.0/lib/native/map/libNativeMap-Linux-amd64-64.so:
>>> /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found
>>> (required by
>>> /opt/accumulo-1.4.0/lib/native/map/libNativeMap-Linux-amd64-64.so)
>>>
>>>          at java.lang.ClassLoader$NativeLibrary.load(Native Method)
>>>
>>>          at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1807)
>>>
>>>          at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1703)
>>>
>>>          at java.lang.Runtime.load0(Runtime.java:770)
>>

Mime
View raw message