accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From William Slacum <wsla...@gmail.com>
Subject Re: [External] Re: accumulo init not working
Date Tue, 19 Jun 2012 03:42:58 GMT
Did your NameNode start up correctly?

If on a local instance, you can verify this by running `jps -lm`. If
jps isn't on your path, it should be located in $JAVA_HOME/bin.

If the NameNode is not running, check your Hadoop logs. The log you
want should have "namenode" in the file name-- it should tell you want
went wrong. I commonly see this when setting up a new instance if I
forget to run `hadoop namenode -format`.

On Mon, Jun 18, 2012 at 11:29 PM, Shrestha, Tejen [USA]
<Shrestha_Tejen@bah.com> wrote:
> Thank you for the quick reply.  You were right I had downloaded the source
> instead of the dist.
> I ran: mvn package && mvn assembly:single –N as per the Accumulo README.
>  I'm not getting the exception anymore but now I can't get it to connect for
> some reason.  Again, Hadoop and Zookeeper are running fine and this is the
> error that I get after $ACCUMULO/bin/accumulo init
>
> 18 23:04:55,614 [ipc.Client] INFO : Retrying connect to server:
> localhost/127.0.0.1:9000. Already tried 0 time(s).
> 18 23:04:56,618 [ipc.Client] INFO : Retrying connect to server:
> localhost/127.0.0.1:9000. Already tried 1 time(s).
> 18 23:04:57,620 [ipc.Client] INFO : Retrying connect to server:
> localhost/127.0.0.1:9000. Already tried 2 time(s).
> 18 23:04:58,621 [ipc.Client] INFO : Retrying connect to server:
> localhost/127.0.0.1:9000. Already tried 3 time(s).
> 18 23:04:59,623 [ipc.Client] INFO : Retrying connect to server:
> localhost/127.0.0.1:9000. Already tried 4 time(s).
> 18 23:05:00,625 [ipc.Client] INFO : Retrying connect to server:
> localhost/127.0.0.1:9000. Already tried 5 time(s).
> 18 23:05:01,625 [ipc.Client] INFO : Retrying connect to server:
> localhost/127.0.0.1:9000. Already tried 6 time(s).
> 18 23:05:02,627 [ipc.Client] INFO : Retrying connect to server:
> localhost/127.0.0.1:9000. Already tried 7 time(s).
> 18 23:05:03,629 [ipc.Client] INFO : Retrying connect to server:
> localhost/127.0.0.1:9000. Already tried 8 time(s).
> 18 23:05:04,631 [ipc.Client] INFO : Retrying connect to server:
> localhost/127.0.0.1:9000. Already tried 9 time(s).
> 18 23:05:04,634 [util.Initialize] FATAL: java.net.ConnectException: Call to
> localhost/127.0.0.1:9000 failed on connection exception:
> java.net.ConnectException: Connection refused
> java.net.ConnectException: Call to localhost/127.0.0.1:9000 failed on
> connection exception: java.net.ConnectException: Connection refused
> at org.apache.hadoop.ipc.Client.wrapException(Client.java:767)
> at org.apache.hadoop.ipc.Client.call(Client.java:743)
> at org.apache.hadoop.ipc.RPC$Invoker.invoke(RPC.java:220)
> at $Proxy0.getProtocolVersion(Unknown Source)
> at org.apache.hadoop.ipc.RPC.getProxy(RPC.java:359)
> at org.apache.hadoop.hdfs.DFSClient.createRPCNamenode(DFSClient.java:106)
> at org.apache.hadoop.hdfs.DFSClient.<init>(DFSClient.java:207)
> at org.apache.hadoop.hdfs.DFSClient.<init>(DFSClient.java:170)
> at
> org.apache.hadoop.hdfs.DistributedFileSystem.initialize(DistributedFileSystem.java:82)
> at org.apache.hadoop.fs.FileSystem.createFileSystem(FileSystem.java:1378)
> at org.apache.hadoop.fs.FileSystem.access$200(FileSystem.java:66)
> at org.apache.hadoop.fs.FileSystem$Cache.get(FileSystem.java:1390)
> at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:196)
> at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:95)
> at org.apache.accumulo.core.file.FileUtil.getFileSystem(FileUtil.java:554)
> at org.apache.accumulo.server.util.Initialize.main(Initialize.java:426)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:597)
> at org.apache.accumulo.start.Main$1.run(Main.java:89)
> at java.lang.Thread.run(Thread.java:680)
> Caused by: java.net.ConnectException: Connection refused
> at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
> at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:567)
> at
> org.apache.hadoop.net.SocketIOWithTimeout.connect(SocketIOWithTimeout.java:206)
> at org.apache.hadoop.net.NetUtils.connect(NetUtils.java:404)
> at org.apache.hadoop.ipc.Client$Connection.setupIOstreams(Client.java:304)
> at org.apache.hadoop.ipc.Client$Connection.access$1700(Client.java:176)
> at org.apache.hadoop.ipc.Client.getConnection(Client.java:860)
> at org.apache.hadoop.ipc.Client.call(Client.java:720)
> ... 20 more
> Thread "init" died null
> java.lang.reflect.InvocationTargetException
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
> at java.lang.reflect.Method.invoke(Method.java:597)
> at org.apache.accumulo.start.Main$1.run(Main.java:89)
> at java.lang.Thread.run(Thread.java:680)
> Caused by: java.lang.RuntimeException: java.net.ConnectException: Call to
> localhost/127.0.0.1:9000 failed on connection exception:
> java.net.ConnectException: Connection refused
> at org.apache.accumulo.server.util.Initialize.main(Initialize.java:436)
> ... 6 more
>
> There was more but I figured it was getting too long.
>
> From: John Vines <john.w.vines@ugov.gov>
> Reply-To: "user@accumulo.apache.org" <user@accumulo.apache.org>
> Date: Monday, June 18, 2012 10:40 PM
> To: "user@accumulo.apache.org" <user@accumulo.apache.org>
> Subject: [External] Re: accumulo init not working
>
> Initial thoughts are that it's not compiled. Either you meant to download
> the dist instead of the src, or you did not build the src. Make sure you
> downloaded the src, or run maven package (requires maven to be installed).
>
> John
>
> On Mon, Jun 18, 2012 at 10:29 PM, Shrestha, Tejen [USA]
> <Shrestha_Tejen@bah.com> wrote:
>>
>> Hi,
>>
>> I am getting this exception when I run $ACCUMULO_HOME/bin/accumulo init:
>>
>> Exception in thread "main" java.lang.NoClassDefFoundError:
>> org/apache/accumulo/start/Platform
>> Caused by: java.lang.ClassNotFoundException:
>> org.apache.accumulo.start.Platform
>> at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
>> at java.security.AccessController.doPrivileged(Native Method)
>> at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
>> at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
>> at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
>> at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
>> Exception in thread "main" java.lang.NoClassDefFoundError:
>> org/apache/accumulo/start/Main
>> Caused by: java.lang.ClassNotFoundException:
>> org.apache.accumulo.start.Main
>> at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
>> at java.security.AccessController.doPrivileged(Native Method)
>> at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
>> at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
>> at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
>> at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
>>
>> Hadoop and Zoopkeeper are running without problems but I can't seem to get
>> past initializing Accumulo.
>
>

Mime
View raw message