accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Vines <john.w.vi...@ugov.gov>
Subject Re: accumulo init not working
Date Tue, 19 Jun 2012 02:40:39 GMT
Initial thoughts are that it's not compiled. Either you meant to download
the dist instead of the src, or you did not build the src. Make sure you
downloaded the src, or run maven package (requires maven to be installed).

John

On Mon, Jun 18, 2012 at 10:29 PM, Shrestha, Tejen [USA] <
Shrestha_Tejen@bah.com> wrote:

>  Hi,
>
>  I am getting this exception when I run $ACCUMULO_HOME/bin/accumulo init:
>
>  Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/accumulo/start/Platform
> Caused by: java.lang.ClassNotFoundException:
> org.apache.accumulo.start.Platform
> at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
> at java.security.AccessController.doPrivileged(Native Method)
> at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
> at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/accumulo/start/Main
> Caused by: java.lang.ClassNotFoundException: org.apache.accumulo.start.Main
> at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
> at java.security.AccessController.doPrivileged(Native Method)
> at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
> at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
>
>  Hadoop and Zoopkeeper are running without problems but I can't seem to
> get past initializing Accumulo.
>

Mime
View raw message