accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steven Troxell <steven.trox...@gmail.com>
Subject Re: Question about special characters in row key
Date Mon, 23 Apr 2012 14:18:06 GMT
Hi everyone,

I'm attempting to use a beta project designed to integrate an RDF engine
with Accumulo.  There seems to be a bug somewhere in the code that fails to
correctly query accumulo that results in failing to limit the results to
the following sparql query:

SELECT ?yr
WHERE {
  ?journal rdf:type bench:Journal .
  ?journal dc:title "Journal 1 (1940)"^^xsd:string .
  ?journal dcterms:issued ?yr
}

I get results back ranging from 1940-1966, while the Hbase integration with
this particular software correctly just returns 1940.  It's fairly
complicated to explain the entire process of how accumulo scans are spawned
from the above query, but I believe I've narrowed down a possible source of
error that I'd like further leads:


I suspect the developers may not be handling the  quotations correctly in
scanning accumulo.  I say this because this is a sample row from the
accumulo shell:

"Journal 1 (1940)"^^http://www.w3.org/2001/XMLSchema#string o:
http://localhost/publications/journals/Journal1/1940
http://purl.org/dc/elements/1.1/title [ROLE1]

>From the shell, I have yet to figure out how to successfully scan for the
row key,  just a straight scan -b "Journal 1 (1940)"^^
http://www.w3.org/2001/XMLSchema#string fails to usage,  wrapping the
rowkey in single quotes seems to return all results, which is what I
suspect happening in the actual software I'm using, as it explains the
behavior I'm seeing.

I'm guessing, but not entirely sure, the developers may have misused the
programatic scans as well on account of not handling the quotations
correctly?  Is this reasonable, and can anyone provide further insight?

Thanks,
Steve

Mime
View raw message