accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keith Turner <ke...@deenlo.com>
Subject Re: Navtive libs in accumulo source
Date Wed, 04 Apr 2012 16:37:19 GMT
It falls back to a java implemention.  The java implementation is
slower, less memory efficient, and can incur the wrath of the Java GC.

Keith

On Wed, Apr 4, 2012 at 12:30 PM, Hider, Sandy <Sandy.Hider@jhuapl.edu> wrote:
> So if the native libs are not required, did I need to do anything else after
> seeing that loading error in the error log or did it fall back automatically
> to another map?
>
>
>
> Sandy
>
>
>
>
>
> From: John Vines [mailto:john.w.vines@ugov.gov]
> Sent: Tuesday, April 03, 2012 10:27 AM
> To: user@accumulo.apache.org
> Subject: Re: Navtive libs in accumulo source
>
>
>
> They are not required, but you get better performance by using the native
> maps. You can build them by going to $ACCUMULO_HOME/src/server/src/main/c++/
> and run make.
>
> John
>
> On Tue, Apr 3, 2012 at 10:17 AM, Hider, Sandy <Sandy.Hider@jhuapl.edu>
> wrote:
>
> I am using Accumulo 1.4 rc5 which I checked out and compiled.  After
> installing on our cloud, the tserver logs were showing an error loading the
> native libraries,  I do not recall which now.  However when I checked my
> accumulo version it did not even have an lib/native directory.
>
>
>
> I was able to find and use the native dir under the Binary distribution of
> 1.3.5 but now I am wondering how should I have acquired the native files?
> Did I miss a step when compiling?
>
>
>
> Thanks
>
>
>
> Sandy
>
>

Mime
View raw message