should there be an assembly jar? The assembly module is just there for orchestrating tasks which must occur after everything builds.

John

Sent from my phone, so pardon the typos and brevity.

On Mar 4, 2012 12:37 AM, "David Medinets" <david.medinets@gmail.com> wrote:
I must be doing something wrong during the compilation but I can't
figure it out. I am using the trunk at revision 1296504. Let me walk
through the steps I am following.

# remove the maven repositories
rm -rf ~/.m2/repository/org/apache/accumulo
# connect to svn working directory
cd ~/workspace/accumulo
# compile accumulo
mvn -Dmaven.test.skip=true install
# see what jars were creating in the maven repository
find ~/.m2/repository/org/apache/accumulo -type f -name '*.jar'

This is that list:

 /home/medined/.m2/repository/org/apache/accumulo/examples-simple/1.5.0-incubating-SNAPSHOT/examples-simple-1.5.0-incubating-SNAPSHOT.jar
 /home/medined/.m2/repository/org/apache/accumulo/wikisearch-ingest/1.5.0-incubating-SNAPSHOT/wikisearch-ingest-1.5.0-incubating-SNAPSHOT.jar
 /home/medined/.m2/repository/org/apache/accumulo/cloudtrace/1.5.0-incubating-SNAPSHOT/cloudtrace-1.5.0-incubating-SNAPSHOT.jar
 /home/medined/.m2/repository/org/apache/accumulo/accumulo-start/1.5.0-incubating-SNAPSHOT/accumulo-start-1.5.0-incubating-SNAPSHOT.jar
 /home/medined/.m2/repository/org/apache/accumulo/accumulo-server/1.5.0-incubating-SNAPSHOT/accumulo-server-1.5.0-incubating-SNAPSHOT.jar
 /home/medined/.m2/repository/org/apache/accumulo/accumulo-core/1.5.0-incubating-SNAPSHOT/accumulo-core-1.5.0-incubating-SNAPSHOT.jar
 /home/medined/.m2/repository/org/apache/accumulo/wikisearch-query/1.5.0-incubating-SNAPSHOT/wikisearch-query-1.5.0-incubating-SNAPSHOT.jar

But I can find evidence of accumulo-assemble

find ~/.m2/repository/org/apache/accumulo -type f -name '*assemble*'

 /home/medined/.m2/repository/org/apache/accumulo/accumulo-assemble/1.5.0-incubating-SNAPSHOT/accumulo-assemble-1.5.0-incubating-SNAPSHOT.pom

Nor has the accumulo-assemble jar file been created in my working directory

find . -type f -name '*assemble*'

This finds no files.

Have I missed a step? Did the process change?