accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Vines <john.w.vi...@ugov.gov>
Subject Re: Maven Artifacts for 1.3.5 missing?
Date Thu, 22 Mar 2012 20:45:05 GMT
Well, I spoke two soon. There are two pending tickets on my plate
(Accumulo-404, running on top of kerberoized hdfs and Accumulo-489,
passwords are not secured with input format) that are a lot easier to
implement, if not only feasible, against 20.203+ (CDH3u0+). It is possible
to do version checking within the code and then calling via reflection, but
that is ugly, ugly code that I think we'd be best to avoid. So I ask the
community, do we have any reasons NOT to migrate our minimum version to
20.203 now that we have a need for a newer version?

John

On Tue, Mar 20, 2012 at 4:29 PM, Robert Vesse <rvesse@yarcdata.com> wrote:

>  I was just interested since 0.20.2 is now two years old if there was any
> compelling reason (other than QA requirements) to stay with that version
>
>  Rob
>
> Rob Vesse -- YarcData.com -- A Division of Cray Inc
> Software Engineer, Bay Area
> m: 925.960.3941  |  o: 925.264.4729 | @: rvesse@yarcdata.com  |  Skype:
> rvesse
> 6210 Stoneridge Mall Rd  |  Suite 120  | Pleasanton CA, 94588
>
>
>  On Mar 20, 2012, at 12:26 PM, John Vines wrote:
>
>  We don't depend on any specific features of 20.205, so I don't know why
> we need to update the minimum version. I know many of us have been working
> with 20.205 without issue.
>
> John
>
> Sent from my phone, so pardon the typos and brevity.
> On Mar 20, 2012 2:50 PM, "Robert Vesse" <rvesse@yarcdata.com> wrote:
>
>>  I haven't looked at the 1.4 branch in detail, did you guys move to a
>> newer version of Hadoop as well, the 1.3.5 release uses the comparatively
>> ancient 0.20.2 version of Hadoop
>>
>> Rob Vesse -- YarcData.com -- A Division of Cray Inc
>> Software Engineer, Bay Area
>> m: 925.960.3941  |  o: 925.264.4729 | @: rvesse@yarcdata.com  |  Skype:
>> rvesse
>> 6210 Stoneridge Mall Rd  |  Suite 120  | Pleasanton CA, 94588
>>
>>
>>  On Mar 19, 2012, at 5:36 PM, Eric Newton wrote:
>>
>> Yes, the 1.4 branch is considered stable.
>>
>>  We've been pounding on 1.4 for quite a while.  The scale of the testing
>> has over a longer period of time, more complete and more aggressive.
>> Another team has been using it for some benchmark testing at scale, and it
>> is remarkable for the *lack* of problems.
>>
>>  No, you cannot mix 1.3 clients with 1.4 servers.  We jumped from 0.3 of
>> thrift to 0.6.1, and that was a huge change for us; I'm not even sure if it
>> can be on-the-wire compatible.  Our goal is to ensure compatibility for
>> 1.X.* level for any constant X.  But a switch from 1.X to 1.Y... we'll
>> remove deprecated APIs, and break on-the-wire compatibility.
>>
>>  -Eric
>>
>>  On Mon, Mar 19, 2012 at 1:57 PM, Robert Vesse <rvesse@yarcdata.com>wrote:
>>
>>>  Is the 1.4.0 branch considered stable enough for use?  And is it the
>>> API compatible between 1.3.5 and 1.4.0 or do both the database and the
>>> client need to be on the exact same version for communication to work
>>> correctly?
>>>
>>>  Rob
>>>
>>>  On Mar 19, 2012, at 10:06 AM, John Vines wrote:
>>>
>>> I believe we don't have them distributed because our poms do not include
>>> adequate licensing info for us to publicly release them. 1.4.0 should be
>>> released when we release it though.
>>>
>>> John
>>>
>>> On Mon, Mar 19, 2012 at 12:58 PM, Robert Vesse <rvesse@yarcdata.com>wrote:
>>>
>>>> Is there a reason why Maven artifacts for 1.3.5 are not available in
>>>> the Apache repositories?
>>>>
>>>> Which Maven repositories (if any) are they available in?
>>>>
>>>> Rob
>>>>
>>>
>>>
>>>
>>
>>
>

Mime
View raw message