accumulo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Vesse <rve...@yarcdata.com>
Subject Re: Accumulo fails to start
Date Thu, 15 Mar 2012 18:27:52 GMT
I am a fairly recent (and reluctant) convert to Mac so am still somewhat vague on correct paths,
setting it to /Library/Java/Home in the accumulo-env.sh and doing an export JAVA_HOME=/Library/Java/Home
were sufficient to get me going

Thanks

Rob

On Mar 14, 2012, at 5:39 PM, Eric Newton wrote:

Well, JAVA_HOME expects a certain file layout... for example, on my mac laptop, /Library/Java/Home
works, but on Linux it's completely different.

It is especially sensitive when building the JNI libs for the native map.

Since it is hard to debug different configurations on different platforms, it would be great
if you could document what works for you.

-Eric

On Wed, Mar 14, 2012 at 4:05 PM, Robert Vesse <rvesse@yarcdata.com<mailto:rvesse@yarcdata.com>>
wrote:
I have tried to set it in that script but the scripts don't seem to accept it - this is further
confused by the fact that a couple of days ago everything worked without any issues and I
haven't changed my config at all

A which java on my command line will give /usr/bin/java as the path but setting JAVA_HOME
to this causes scripts to fail completely because they blindly append /bin/java to the path,
yet bizarrely setting it to /usr gives the warning seen in my email

I will experiment and see whether this is the cause of the issue but should there not be a
way to actually show a useful error message to the user in this case?

Rob

On Mar 14, 2012, at 12:56 PM, Eric Newton wrote:

Are you setting JAVA_HOME in conf/accumulo-env.sh ?

If you are setting configuration in your environment, it may not survive an ssh to localhost.

-Eric

On Wed, Mar 14, 2012 at 3:51 PM, Robert Vesse <rvesse@yarcdata.com<mailto:rvesse@yarcdata.com>>
wrote:
I'm having problems with Accumulo not starting correctly - yet from the command line it looks
to start fine i.e. when I run bin/start-all.sh I see the following output:

Starting tablet servers and loggers .... done
Unable to find a $JAVA_HOME at "/usr", continuing with system-provided Java...
Unable to find a $JAVA_HOME at "/usr", continuing with system-provided Java...
Starting logger on localhost
Starting tablet server on localhost
Starting master on localhost
Starting garbage collector on localhost
Starting monitor on localhost
Starting tracer on localhost

Yet if I try to start an accumulo shell with bin/accumulo shell -u root I get the following
error:

14 12:41:27,472 [impl.ServerClient] WARN : Failed to find an available server in the list
of servers: []
14 12:41:27,473 [shell.Shell] ERROR: org.apache.accumulo.core.client.AccumuloException: org.apache.thrift.transport.TTransportException:
Failed to connect to a server

I looked under the logs/ directory and see that a bunch of logs are created but they are all
zero bytes in size so no helpful hints there :-(

I have followed the README to configure everything appropriately for a single node setup (I
have Hadoop and Zookeeper running fine) and I actually had Accumulo working correctly a couple
of days ago yet now I am unable to start things up again.  I have tried reformatting my HDFS
(as this is just a dev setup) and starting from scratch but I consistently hit this issue
that Accumulo just does not start properly.

Any help or guidance on this would be much appreciated

Rob





Mime
View raw message