accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [accumulo] ctubbsii opened a new issue #1195: Update EasyMock / PowerMock / JUnit to get tests passing with Java 11
Date Tue, 11 Jun 2019 07:08:37 GMT
ctubbsii opened a new issue #1195: Update EasyMock / PowerMock / JUnit to get tests passing
with Java 11
URL: https://github.com/apache/accumulo/issues/1195
 
 
   EasyMock fails to create mock objects because it doesn't recognize Java 11's class file
version 55. PowerMock is likely broken also with Java 11, and any change to either of those
may require JUnit changes. However, I don't think there is any version of PowerMock that supports
JUnit 5 yet, so this should be a conservative update of these utilities... to find the versions
that work on Java 11 (if any).
   
   ```java
   EasyMock.createMock(classToMock);
   ```
   throws:
   ```java
   java.lang.IllegalArgumentException: Unsupported class file major version 55
   	at org.apache.accumulo.core.clientImpl.ThriftTransportKeyTest.testSaslPrincipalIsSignificant(ThriftTransportKeyTest.java:108)
   ```

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services

Mime
View raw message