accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [accumulo] hkeebler edited a comment on issue #1084: Tests failing running against standalone instance
Date Thu, 02 May 2019 20:35:43 GMT
hkeebler edited a comment on issue #1084: Tests failing running against standalone instance
URL: https://github.com/apache/accumulo/issues/1084#issuecomment-488277798
 
 
   The following tests are still producing either errors or failures.  Looked for some common
themes.  An async timing thing may be part of the issue.  Should these tests be worked off
using this ticket or should a separate git issue be created for each test or issue group?
 
   
   **Test failures:**
   - CleanWalIT -  a timing thing - the flush of accumulo.metadata does not get rid of log
entries before the check - takes several seconds.
   - AccumuloClientIT - thinks it is a server not a client - might be okay
   - BinaryStressIT - a timing thing maybe but just does not do what is expected, i.e., split
based on 10K threshold
   - YieldScannersIT  - Iterator appears to not be cleaned/removed after test in standalone
env - it continues to increment.
   - IteratorEnvIT - Test internal iterator subclasses use Assert which produces "class not
found" error on the Tserver executing the scan.  Do we want to add the junit jar to the prod
libs or just say that this is not a candidate for the Standalone tests?
   - ManyWriteAheadLogsIT - the Standalone instance just doesn't produce alot of Wals - only
2 vs. >50.   
   - ReadWritIT  - parsing error - see ReadWriteIT comment
   
   **This group produces a "file not found" ERROR** 
   - BulkImportValumeIT 
   - ImportExportIT 
   - TokenFileIT 
   - CompactionIT 
   - BulkFileIT 
   - BulkIT 
   - BulkSplitOptimizationIT 
   
   **This group times out**
   - DeleteTableDuringSplitIT 
   - MergIT - worked with timeout.factor=3
   - CreateInitialSplitsIT - still need to update the time > 5 for a couple of the tests
   - ScanSessionTimeOutIT - worked with timeout.factor=3
   - SessionBlockVerifyIT - totally hangs on delete and may be what screwed up the following
tests.  Had to restart the server twice to remove hung "deleteing" table
   - FateStarvationIT - worked with timeout.factor=3
   - BigRootTabletIT - worked with timeout.factor=3
   - RecoveryCompactionsAreFlushesIT - worked with timeout.factor=3
   
   
   
   

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services

Mime
View raw message