accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-4757) Update bundled jQuery for 2.0 monitor
Date Tue, 12 Dec 2017 23:06:00 GMT


Christopher Tubbs commented on ACCUMULO-4757:

If we can get Bootstrap 3.3.7 to play nice with jQuery 3.2.1, that'd be ideal for now. As
for the jquery-ui stuff... are we even using any of that? I'm not sure how to tell. jquery-ui
hasn't been updated in forever... but I'm also not sure what we're using it for. I don't think
Flot used it. Maybe Bootstrap or select2?

> Update bundled jQuery for 2.0 monitor
> -------------------------------------
>                 Key: ACCUMULO-4757
>                 URL:
>             Project: Accumulo
>          Issue Type: Task
>          Components: monitor
>            Reporter: Christopher Tubbs
>            Assignee: Michael Miller
>            Priority: Critical
>             Fix For: 2.0.0
> JQuery is a bit out of date. It's currently at 2.2.4, which was the last version released
in the 2.x series. Versions prior to 3.x are no longer receiving patches, and have known bugs.
> We should update to the latest versions to avoid bundling any versions which may have
known bugs. The latest version is currently 3.2.1.
> (Note: I've checked flot, jquery-ui, select2, and bootstrap, and we are currently using
the latest versions of all of those right now. Along with jQuery, that is an exhaustive list
of our external monitor resources.)

This message was sent by Atlassian JIRA

View raw message