accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ivan Bella (JIRA)" <j...@apache.org>
Subject [jira] [Created] (ACCUMULO-4715) Accumulo upgrade path fails from 1.6 to 1.7/1.8 if PerTableVolumeChooser or PreferredTableVolumeChooser is the default
Date Wed, 04 Oct 2017 15:09:00 GMT
Ivan Bella created ACCUMULO-4715:
------------------------------------

             Summary: Accumulo upgrade path fails from 1.6 to 1.7/1.8 if PerTableVolumeChooser
or PreferredTableVolumeChooser is the default
                 Key: ACCUMULO-4715
                 URL: https://issues.apache.org/jira/browse/ACCUMULO-4715
             Project: Accumulo
          Issue Type: Bug
    Affects Versions: 1.8.1, 1.8.0, 1.7.3, 1.7.2
            Reporter: Ivan Bella
            Assignee: Ivan Bella
            Priority: Critical
             Fix For: 1.7.4, 1.8.2, 2.0.0


The createReplicationTable method in the MetadataTableUtil used to create the replication
table when upgrading from 1.6 and calls the default volume chooser to get a location.  The
problem is that at that point the replication table does not exist and the PerTableVolumeChooser
and the PreferredTableVolumeChooser classes will call the getTableConfiguration with the supplied
table id which will return null.  Subsequently those volume choosers will throw a NullPointerException
and the upgrade will fail.  Both of these volume choosers should instead use the fallbacks
instead of failing.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message