accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Miller (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-4703) Attempt to pull all dependencies to latest version
Date Fri, 29 Sep 2017 16:51:07 GMT


Michael Miller commented on ACCUMULO-4703:

[~findepi] Please see the mailing list discussion about Guava dependecies:
In particular see my comment about Hadoop:
We are tied down to Guava 14 because of Hadoop. This is the work
around since we can't just update Guava. Previously, we had just avoided
using 14 code that wasn't around anymore. Which was OK until code was
deprecated after version 14 and then removed, like in the case with

> Attempt to pull all dependencies to latest version
> --------------------------------------------------
>                 Key: ACCUMULO-4703
>                 URL:
>             Project: Accumulo
>          Issue Type: Task
>            Reporter: Keith Turner
>            Assignee: Michael Miller
>            Priority: Blocker
>             Fix For: 2.0.0
>          Time Spent: 1h 20m
>  Remaining Estimate: 0h
> This is issue is motivated by discussion in ACCUMULO-4701.   For 2.0.0 we should attempt
to use the latest version of any direct dependencies.   Not doing so may force user to use
older versions of dependencies with bugs and security problems. 
> ACCUMULO-4701 provides an example of this where Accumulo using methods that exist in
an older version of Guava but are dropped in a new version prevent a user from using newer

This message was sent by Atlassian JIRA

View raw message