accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Miller (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-4703) Attempt to pull all dependencies to latest version
Date Fri, 22 Sep 2017 16:05:01 GMT


Michael Miller commented on ACCUMULO-4703:

I was able to find a usable version of Zookeeper 3.5.x with release 3.5.2-alpha.  I don't
think 3.5 is ready for use though as I couldn't even get 3.5.3-beta to work.  There were some
minor changes to MAC to use the new configuration.  Here is my branch for future reference
when they release a stable version:

> Attempt to pull all dependencies to latest version
> --------------------------------------------------
>                 Key: ACCUMULO-4703
>                 URL:
>             Project: Accumulo
>          Issue Type: Task
>            Reporter: Keith Turner
>            Assignee: Michael Miller
>            Priority: Blocker
>             Fix For: 2.0.0
>          Time Spent: 40m
>  Remaining Estimate: 0h
> This is issue is motivated by discussion in ACCUMULO-4701.   For 2.0.0 we should attempt
to use the latest version of any direct dependencies.   Not doing so may force user to use
older versions of dependencies with bugs and security problems. 
> ACCUMULO-4701 provides an example of this where Accumulo using methods that exist in
an older version of Guava but are dropped in a new version prevent a user from using newer

This message was sent by Atlassian JIRA

View raw message