accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Turner (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-4701) Shade Guava dependency
Date Mon, 11 Sep 2017 13:26:00 GMT


Keith Turner commented on ACCUMULO-4701:

[~findepi] if we were to remove any usage of guava Beta or deprecated methods, do you think
that would solve your problem?  That would be the path I would like to take.  We will need
to do it to upgrade our guava version anyway.  Maybe this could be done for 1.7.4 and 1.8.2,
depending on how disruptive it is.

> Shade Guava dependency
> ----------------------
>                 Key: ACCUMULO-4701
>                 URL:
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: build
>    Affects Versions: 1.7.3
>            Reporter: Piotr Findeisen
>            Assignee: Christopher Tubbs
> [{{presto-accumulo}}|]
connector embeds Accumulo client {{org.apache.accumulo:accumulo-core}}. Accumulo uses Guava.
Since Guava APIs are not strictly backwards compatible, it's necessary to shade guava dependency
or library users need to use same Guava version (i.e. cannot upgrade/downgrade at will).
> Please shade Guava dependency.

This message was sent by Atlassian JIRA

View raw message