accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Turner (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-4619) Add splits hung forever
Date Wed, 05 Apr 2017 17:25:41 GMT


Keith Turner commented on ACCUMULO-4619:

I learned a bit more, the LoggingRunnable created by NamingThreadFactory is working after

The split code using the thread pool was calling submit() which returns a Future.  When a
Future is returned the thread pool forwards exceptions to the Future, so it does not make
it to LoggingRunnable.  This makes sense.  However, the accumulo split code wasn't doing anything
with the Future.  I tried changing the split code to call `execute()` instead of `submit()`
and then LoggingRunnable did print the Error.

> Add splits hung forever
> -----------------------
>                 Key: ACCUMULO-4619
>                 URL:
>             Project: Accumulo
>          Issue Type: Bug
>    Affects Versions: 1.7.3, 1.8.1
>            Reporter: Keith Turner
>            Assignee: Keith Turner
>             Fix For: 1.7.4, 1.8.2, 2.0.0
> I ran into a problem where addsplits was hanging forever and no errors were printed by
Accumulo even when I set the log level to trace.  I finally figured out the problem was that
I had the wrong version of thrift on the classpath (0.9.1 vs 0.9.3).  Accumulo 1.8.1 was trying
to use a method that did not exist in thrift 0.9.1 :(  
> This missing method caused a NoSuchMethodError to be thrown.  The Accumulo split code
only caught Exception and therefore did not handle this.  Also nothing was printed for this.
> The split code should be fixed to not silently drop errors.

This message was sent by Atlassian JIRA

View raw message