accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Miller (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-4600) Shell does not fall back to accumulo-site.xml when on classpath
Date Tue, 07 Mar 2017 17:56:38 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-4600?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15899846#comment-15899846
] 

Michael Miller commented on ACCUMULO-4600:
------------------------------------------

[~elserj] Thoughts on remedies? 

> Shell does not fall back to accumulo-site.xml when on classpath
> ---------------------------------------------------------------
>
>                 Key: ACCUMULO-4600
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-4600
>             Project: Accumulo
>          Issue Type: Bug
>          Components: shell
>    Affects Versions: 1.7.3
>            Reporter: Josh Elser
>            Priority: Critical
>
> When inspecting 1.7.3-rc1 for the VOTE, I did the following steps:
> * Unpack bin-tarball
> * Copy 3gb native example confs
> * Set {{instance.volumes}} in accumulo-site.xml
> * {{export ACCUMULO_HOME="$(pwd)"}}
> * {{./bin/accumulo init}}
> * {{./bin/start-all.sh}}
> * {{./bin/accumulo shell -u root}}
> The shell failed to connect stating that no tservers were running. By turning on the
debug option to the shell, I could see that the wrong HDFS directory was being used to find
the Accumulo instance ID, {{/accumulo}} instead of {{/accumulo173rc1}}.
> This appears to be because of {{ClientContext#convertClientConfig(Configuration)}} and
 {{Shell#getZooInstance(String, String, ClientConfiguration}}. The client configuration is
empty, therefore, all values end up being pulled from the {{DefaultConfiguration}} instance
instead of the accumulo-site.xml which is on the classpath.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message