accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-4551) Update to thrift-0.10.0
Date Wed, 08 Feb 2017 04:34:41 GMT


Christopher Tubbs commented on ACCUMULO-4551:

I worked through all the issues, but... for some reason, I see {{Received 1}} now in the shell,
every time I run with the new thrift library... and that goes away when I run the shell with

This is very strange... and seems completely unrelated, but as far as I can tell it's the
direct result of using this new thrift version.

It seems to be happening in the {{listLocalUsers()}} command in java, because even with tab
completion disabled, it still shows up when I do a {{users}} command in the shell. Running
{{userpermissions}} results in a bunch of them. If this ends up being inside the {{TProtocol}}
stuff, I might need help troubleshooting.

In the meantime, I'll put together a PR.

> Update to thrift-0.10.0
> -----------------------
>                 Key: ACCUMULO-4551
>                 URL:
>             Project: Accumulo
>          Issue Type: Improvement
>            Reporter: Christopher Tubbs
>            Assignee: Christopher Tubbs
>             Fix For: 2.0.0
> Thrift just released 0.10.0, so we should update to that, for the 2.0.0 branch. It shouldn't
have much impact on us (I'll test it out), but it'd be good for future-proofing the 2.0.x
releases against later thrift bugfixes.

This message was sent by Atlassian JIRA

View raw message