accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Miller (JIRA)" <j...@apache.org>
Subject [jira] [Created] (ACCUMULO-4525) Replace meaningless method names
Date Tue, 22 Nov 2016 15:21:58 GMT
Michael Miller created ACCUMULO-4525:
----------------------------------------

             Summary: Replace meaningless method names
                 Key: ACCUMULO-4525
                 URL: https://issues.apache.org/jira/browse/ACCUMULO-4525
             Project: Accumulo
          Issue Type: Improvement
            Reporter: Michael Miller
            Priority: Minor
             Fix For: 1.7.3, 1.8.1, 2.0.0


There are a few abbreviated method names reused throughout the code that are meaningless to
new users. Method names such as "nk", "nf" or "ane" are not helpful when trying to determine
how a class works. This seems to only occur in Tests but I think it would improve readability
a lot, especially for newbies. I for one think Tests are a good place to learn how a class
works and choosing brevity over clarity greater hinders the readability of a Test.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message