accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-2844) Remove master/slave terminology
Date Tue, 13 Sep 2016 02:06:20 GMT


Christopher Tubbs commented on ACCUMULO-2844:

This ticket is primarily about removing unnecessarily racially charged terminology. So, if
we've achieved that (and I personally think we have, since master has contexts beyond slavery
which are applicable here, albeit poorly), then I think this issue can be closed.

A secondary goal was to align the names to their function in Accumulo. I'm not particularly
fond of "Coordinator", because it doesn't fully encapsulate what the Master process does,
and "coordinator" is still pretty generic and says the same thing. Renaming that is very disruptive,
too... package names, class names, configuration properties, maven coordinates, scripts, etc.
That's much different than renaming "slaves" to "tservers" or "peers", which added clarification
and was minimally disruptive.

Given how disruptive it would be, I'd be against renaming "master" unless we have strong consensus
that the new name is *significantly* better than "master". "coordinator" doesn't make the
cut for me, personally.

I think we should close this issue as done, and create new issues to address further naming/functionality
alignments, as needed. For those new issues, we can focus on discussing new potential names,
and easing the transition to mitigate impact to users.

> Remove master/slave terminology
> -------------------------------
>                 Key: ACCUMULO-2844
>                 URL:
>             Project: Accumulo
>          Issue Type: Task
>    Affects Versions: 1.5.0, 1.5.1, 1.6.0
>            Reporter: Sean Busbey
>             Fix For: 2.0.0
>          Time Spent: 1h
>  Remaining Estimate: 0h
> I'd like to remove our use of master/slave terminology in favor of something that doesn't
carry a racially charged meaning.
> As a side effect I'd also like to pick names that carry better meaning of how things
work within Accumulo.
> In the case of a single cluster, I'd like to
> * Change the Master role to Coordinator
> * Change the associated master server package to coordinator
> * Change the master configuration file to be named coordinators
> * Change the slaves configuration file to be named tservers
> In the case of the in-progress replication work I'd like to change terminology:
> * use _Primary Cluster_  in place of _Master Cluster_
> * use _Replica Clusters_ in place of _Slave Clusters_
> I intend to do this in all active branches in a way that maintains compatibility of existing
configuration files and serialized actions (i.e. fate operations) within their major branch.
In the current unreleased major branch I expect upgrading will require user action (e.g. renaming
configuration files).

This message was sent by Atlassian JIRA

View raw message