accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2844) Remove master/slave terminology
Date Tue, 13 Sep 2016 01:27:20 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2844?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15485895#comment-15485895
] 

Josh Elser commented on ACCUMULO-2844:
--------------------------------------

bq. I think this is sufficiently done, and can be closed. Is there more to be done?

Is there interest to also rename the "master" Accumulo process? Personally, I would like to
see s/master/coordinator/ and s/garbage collector/janitor/, but I'm not sure what others think
could/should be done for 2.0. In writing/speaking, I think both of these renames would remove
a bit of ambiguity (e.g. does "master" refer to the "accumulo master" or a special physical
node which different hardware than the other nodes? does garbage collection refer to the JVM
or the accumulo "garbage collector" process?), and help ignore the previous debate of "\[offensiveness
with the lack of slaves\]".

There was concern about API compatibility also previously stated with such a rename. At a
quick glance, I only see {{getMasterStats}} on the thrift RPC method side. As everyone knows,
Thrift is great about letting us build cross-version compatibility between clients/servers.
I would think that we could rename most instances, and leave those necessary for backwards
compatibility there. I believe that we can change the general tone to something that provides
greater clarity and reduces the likelihood to offend someone.

> Remove master/slave terminology
> -------------------------------
>
>                 Key: ACCUMULO-2844
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2844
>             Project: Accumulo
>          Issue Type: Task
>    Affects Versions: 1.5.0, 1.5.1, 1.6.0
>            Reporter: Sean Busbey
>             Fix For: 2.0.0
>
>          Time Spent: 1h
>  Remaining Estimate: 0h
>
> I'd like to remove our use of master/slave terminology in favor of something that doesn't
carry a racially charged meaning.
> As a side effect I'd also like to pick names that carry better meaning of how things
work within Accumulo.
> In the case of a single cluster, I'd like to
> * Change the Master role to Coordinator
> * Change the associated master server package to coordinator
> * Change the master configuration file to be named coordinators
> * Change the slaves configuration file to be named tservers
> In the case of the in-progress replication work I'd like to change terminology:
> * use _Primary Cluster_  in place of _Master Cluster_
> * use _Replica Clusters_ in place of _Slave Clusters_
> I intend to do this in all active branches in a way that maintains compatibility of existing
configuration files and serialized actions (i.e. fate operations) within their major branch.
In the current unreleased major branch I expect upgrading will require user action (e.g. renaming
configuration files).



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message