accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Wall (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-4349) Test failures in master after port-search changes
Date Tue, 21 Jun 2016 02:17:58 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-4349?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15340902#comment-15340902
] 

Michael Wall commented on ACCUMULO-4349:
----------------------------------------

[~elserj] It is building fine for me on Linux.  Also noticed https://travis-ci.org/apache/accumulo/builds/138487976
and https://builds.apache.org/view/A/view/Accumulo/job/Accumulo-1.8/38/

I am getting this failure with java 8 on my mac on the 1.8 and master branches.  Verified
the error started with commit 7f8f66d8a066dbfe118e00e19984bb18f3adfabd for ACCUMULO-4331.
 
For the 1.8 branch with java 7, I am getting the same failures.  Master won't run with java
7 anymore.

I can look more tomorrow.

> Test failures in master after port-search changes
> -------------------------------------------------
>
>                 Key: ACCUMULO-4349
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-4349
>             Project: Accumulo
>          Issue Type: Bug
>            Reporter: Josh Elser
>            Assignee: Josh Elser
>            Priority: Blocker
>             Fix For: 1.8.0, 1.9.0
>
>
> {noformat}
> Tests run: 9, Failures: 2, Errors: 1, Skipped: 0, Time elapsed: 0.73 sec <<<
FAILURE! - in org.apache.accumulo.server.util.TServerUtilsTest
> testStartServerUsedPortWithSearch(org.apache.accumulo.server.util.TServerUtilsTest) 
Time elapsed: 0.379 sec  <<< FAILURE!
> java.lang.AssertionError: expected:<1025> but was:<1024>
> 	at org.apache.accumulo.server.util.TServerUtilsTest.testStartServerUsedPortWithSearch(TServerUtilsTest.java:258)
> testStartServerUsedPort(org.apache.accumulo.server.util.TServerUtilsTest)  Time elapsed:
0.003 sec  <<< FAILURE!
> java.lang.AssertionError: Expected exception: java.net.UnknownHostException
> testStartServerFreePort(org.apache.accumulo.server.util.TServerUtilsTest)  Time elapsed:
0.002 sec  <<< ERROR!
> java.net.UnknownHostException: Unable to find a listen port
> 	at org.apache.accumulo.server.util.TServerUtilsTest.startServer(TServerUtilsTest.java:341)
> 	at org.apache.accumulo.server.util.TServerUtilsTest.testStartServerFreePort(TServerUtilsTest.java:220)
> {noformat}
> These seem like they might be related to your changes in ACCUMULO-4331, [~dlmarion].
Can you please take a look?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message