accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Drob (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-3923) VFS ClassLoader doesnt' work with KeywordExecutable
Date Fri, 10 Jun 2016 20:39:21 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-3923?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15325250#comment-15325250
] 

Mike Drob commented on ACCUMULO-3923:
-------------------------------------

Tried testing this today, had a lot of trouble getting things working.

I was using CDH5.7

Some issue that I noticed:
* It is not clear at all what {{general.vfs.classpaths}} value is supposed to be. A directory?
A java classpath style wildcard? A regex for jars?
** I tried this as a directory and it didn't seem to pick up the jars.
** I tried this as a regex or single jar and the process became unresponsive.
* I tested this by moving {{accumulo-shell}} jar to hdfs and then running {{bin/accumulo help}}
and observing that it did not include the shell command.
* When running {{accumulo classpath}} I got a {{Level 5: Mystery Classloader (someone probably
added a classloader and didn't update the switch statement in org.apache.accumulo.start.classloader.vfs.AccumuloVFSClassLoader)
VFS classpaths items are:}}. There were no classpath items here, but maybe the updates to
the VFS loader slipped in something new. Are these App Context ClassLoaders?

Lots of these probably need to be broken out into their own issues, but overall this is screaming
like something that is too big to fix in 1.7.2. Assigning this to you, [~dlmarion] to triage
as appropriate.


> VFS ClassLoader doesnt' work with KeywordExecutable
> ---------------------------------------------------
>
>                 Key: ACCUMULO-3923
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-3923
>             Project: Accumulo
>          Issue Type: Bug
>            Reporter: Josh Elser
>            Priority: Critical
>             Fix For: 1.7.3, 1.8.0
>
>
> Trying to make the VFS classloading stuff work and it doesn't seem like ServiceLoader
is finding any of the KeywordExecutable implementations.
> Best I can tell after looking into this, VFSClassLoader (created by AccumuloVFSClassLoader)
has all of the jars listed as resources, but when ServiceLoader tries to find the META-INF/services
definitions, it returns nothing, and thus we think the keyword must be a class name. Seems
like a commons-vfs bug.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message