accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-4162) Invalid ZooKeeper version warning message
Date Thu, 17 Mar 2016 04:12:33 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-4162?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15198709#comment-15198709
] 

ASF GitHub Bot commented on ACCUMULO-4162:
------------------------------------------

GitHub user ctubbsii opened a pull request:

    https://github.com/apache/accumulo/pull/81

    ACCUMULO-4162 Fix zookeeper version matching

    In the course of fixing ACCUMULO-4162, I noticed lots of other small script problems which
were just as likely to mess up users. So, I ran shellcheck on all the scripts in assemble/bin,
and a little bit outside there. This is the results for the 1.6 branch, and could use a bit
of a review/manual testing to make sure they work as expected.
    
    Any help checking these out would be greatly appreciated.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/ctubbsii/accumulo shellcheck-pedantry

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/accumulo/pull/81.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #81
    
----
commit 0e5657945de3494f6790284f13044bff5db4aa57
Author: Christopher Tubbs <ctubbsii@apache.org>
Date:   2016-03-17T04:04:20Z

    ACCUMULO-4162 Fix zookeeper version matching
    
    Apply many shellcheck fixes

----


> Invalid ZooKeeper version warning message
> -----------------------------------------
>
>                 Key: ACCUMULO-4162
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-4162
>             Project: Accumulo
>          Issue Type: Bug
>          Components: scripts
>    Affects Versions: 1.7.1
>            Reporter: Josh Elser
>            Assignee: Christopher Tubbs
>             Fix For: 1.6.6, 1.7.2, 1.8.0
>
>
> Saw this when running Sven's docker image with ZooKeeper-3.4.8:
> {noformat}
> WARN : Using Zookeeper /zookeeper-3.4.8/zookeeper-3.4.8.  Use version 3.4.0 or greater.
Older versions may not work reliably.
> {noformat}
> 3.4.8 > 3.4.0. Looks like the version detection is a bit busted.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message