accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-4162) Invalid ZooKeeper version warning message
Date Tue, 15 Mar 2016 19:53:33 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-4162?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15196076#comment-15196076
] 

Christopher Tubbs commented on ACCUMULO-4162:
---------------------------------------------

Replacing
{code}
ZOOKEEPER_VERSION=${ZOOKEEPER_VERSION##$ZOOKEEPER_HOME/zookeeper-}
{code}
with
{code}
ZOOKEEPER_VERSION=${ZOOKEEPER_VERSION##*/zookeeper-}
{code}
is probably good.

I'm also not a fan of the needing to escape the comparison operator. We should use double
brackets. It's probably a good idea to just run the whole script through shellcheck, too.

> Invalid ZooKeeper version warning message
> -----------------------------------------
>
>                 Key: ACCUMULO-4162
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-4162
>             Project: Accumulo
>          Issue Type: Bug
>          Components: scripts
>    Affects Versions: 1.7.1
>            Reporter: Josh Elser
>
> Saw this when running Sven's docker image with ZooKeeper-3.4.8:
> {noformat}
> WARN : Using Zookeeper /zookeeper-3.4.8/zookeeper-3.4.8.  Use version 3.4.0 or greater.
Older versions may not work reliably.
> {noformat}
> 3.4.8 > 3.4.0. Looks like the version detection is a bit busted.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message