accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-3939) Accumulo AuditedSecurityOperation is not initialized properly
Date Mon, 27 Jul 2015 21:41:04 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-3939?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14643453#comment-14643453
] 

Josh Elser commented on ACCUMULO-3939:
--------------------------------------

Looks like the patch works as expected. It would be good to add a test for this case but I'm
not sure the best way to add this (HdfsZooInstance makes this hard to do). Maybe a comment
in the code would suffice explaining why the method exists (but duplicates the one in the
parent class). [~james.mello], want to add a comment and put up a new patch? Otherwise, I
can just add one on commit.

Also, do you want to open a separate ticket for reviewing the audited operations? Your table
has some nice information -- I don't want to get these two issues mixed together unnecessarily.

> Accumulo AuditedSecurityOperation is not initialized properly
> -------------------------------------------------------------
>
>                 Key: ACCUMULO-3939
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-3939
>             Project: Accumulo
>          Issue Type: Bug
>    Affects Versions: 1.5.3
>            Reporter: James Mello
>            Priority: Critical
>              Labels: easyfix
>         Attachments: ACCUMULO-3939.patch, generic_logger.xml
>
>
> While reading the source I found out that the AuditedSecurityOperation is never initialized
properly.
> The AuditSecurityOperation does not contain a getInstance() static method. This in turn
just calls the SecurityOperation getInstance() method. Because this is called in a static
manner the getInstance(String instanceId, boolean initialize) is called against the SecurityOperation
class not the AuditedSecurityOperation class.
> This should just be a simple fix that adds the getInstance() method to the AuditedSecurityOperation
class.
> This is critical as we are in need of this security auditing to meet Information Assurance
requirements for an upcoming major release of our software.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message