accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Billie Rinaldi (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ACCUMULO-3779) Shell fails to connect to ZooKeeper when client.conf doesn't exist
Date Thu, 07 May 2015 18:06:01 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-3779?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Billie Rinaldi updated ACCUMULO-3779:
-------------------------------------
    Affects Version/s: 1.6.0
                       1.6.1
                       1.6.2

> Shell fails to connect to ZooKeeper when client.conf doesn't exist
> ------------------------------------------------------------------
>
>                 Key: ACCUMULO-3779
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-3779
>             Project: Accumulo
>          Issue Type: Bug
>          Components: shell
>    Affects Versions: 1.6.0, 1.6.1, 1.6.2
>            Reporter: Josh Elser
>            Assignee: Josh Elser
>            Priority: Blocker
>             Fix For: 1.7.0
>
>
> Stood up 1.7.0, forgot to make a client.conf (there wasn't a template included in the
example confs).
> Tried to connect to the shell and it just timed out trying to talk to ZooKeeper at the
default host of "localhost:2181". I feel like this is a regression against 1.6 because things
used to attempt to work by trying to read accumulo-site.xml.
> If we are intentionally not supporting automatic fallback to accumulo-site.xml, we should
have a log message that informs the user when we construct a ClientConfiguration without any
actual configuration (as that's likely an error).



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message