accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-3779) Shell fails to connect to ZooKeeper when client.conf doesn't exist
Date Thu, 07 May 2015 17:53:01 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-3779?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14533082#comment-14533082
] 

Josh Elser commented on ACCUMULO-3779:
--------------------------------------

bq. I don't remember completely dropping support for fallback to using accumulo-site.xml

Neither do I, which is what confused me. Given Billie's assessment, maybe I just didn't notice
it?

bq. I wonder if the template should be named "client.conf.template", though, so it's not automatically
used (could interfere with existing deployments if a user has one in a lower-priority location)?

You think that's a big concern? The admin would have had to copy that new file from the examples
(or the configuration script) into the conf dir. I was thinking that it would only be a concern
if someone copies it to a new install and forgets to change it.

> Shell fails to connect to ZooKeeper when client.conf doesn't exist
> ------------------------------------------------------------------
>
>                 Key: ACCUMULO-3779
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-3779
>             Project: Accumulo
>          Issue Type: Bug
>          Components: shell
>            Reporter: Josh Elser
>            Assignee: Josh Elser
>            Priority: Blocker
>             Fix For: 1.7.0
>
>
> Stood up 1.7.0, forgot to make a client.conf (there wasn't a template included in the
example confs).
> Tried to connect to the shell and it just timed out trying to talk to ZooKeeper at the
default host of "localhost:2181". I feel like this is a regression against 1.6 because things
used to attempt to work by trying to read accumulo-site.xml.
> If we are intentionally not supporting automatic fallback to accumulo-site.xml, we should
have a log message that informs the user when we construct a ClientConfiguration without any
actual configuration (as that's likely an error).



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message