accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-3779) Shell fails to connect to ZooKeeper when client.conf doesn't exist
Date Tue, 26 May 2015 19:18:20 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-3779?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14559663#comment-14559663
] 

Christopher Tubbs commented on ACCUMULO-3779:
---------------------------------------------

And the place to put that file is probably ~/.accumulo/

> Shell fails to connect to ZooKeeper when client.conf doesn't exist
> ------------------------------------------------------------------
>
>                 Key: ACCUMULO-3779
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-3779
>             Project: Accumulo
>          Issue Type: Bug
>          Components: shell
>            Reporter: Josh Elser
>            Assignee: Josh Elser
>            Priority: Blocker
>              Labels: 1.7.0_QA
>             Fix For: 1.7.0
>
>          Time Spent: 20m
>  Remaining Estimate: 0h
>
> Stood up 1.7.0, forgot to make a client.conf (there wasn't a template included in the
example confs).
> Tried to connect to the shell and it just timed out trying to talk to ZooKeeper at the
default host of "localhost:2181". I feel like this is a regression against 1.6 because things
used to attempt to work by trying to read accumulo-site.xml.
> If we are intentionally not supporting automatic fallback to accumulo-site.xml, we should
have a log message that informs the user when we construct a ClientConfiguration without any
actual configuration (as that's likely an error).



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message