accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-3216) VolumeManagerImpl.findMatchingFilesystem is lacking
Date Fri, 29 May 2015 22:27:18 GMT


Christopher Tubbs commented on ACCUMULO-3216:

I think for this issue, it'd be sufficient to fix the NPE, and replace it with a better error
condition, so a user can understand what happened.

We should also recommend users use consistent configuration (probably prefer DNS) - see ACCUMULO-3872

> VolumeManagerImpl.findMatchingFilesystem is lacking
> ---------------------------------------------------
>                 Key: ACCUMULO-3216
>                 URL:
>             Project: Accumulo
>          Issue Type: Bug
>          Components: tserver
>    Affects Versions: 1.6.1
>            Reporter: Josh Elser
>            Priority: Critical
>             Fix For: 1.6.3, 1.7.1, 1.8.0
> Part of the problem found in ACCUMULO-3215
> On a standalone instance, I configured accumulo-site with
> {noformat}
>   <property>
>     <name>instance.volumes</name>
>     <value>hdfs://localhost:8020/accumulo1.6.2</value>
>   </property>
> {noformat}
> But in core-site.xml
> {noformat}
>     <property>
>         <name>fs.defaultFS</name>
>         <value>hdfs://</value>
>     </property>
> {noformat}
> I then tried to export a table and re-import it (essentially followed
> Ultimately, in the fate op for import table, we tried to find the matching filesystem
for out of choices: localhost:8020. This then threw an NPE because there are
no matching options. Which is a really nasty issue...
> We could try to make things a little better by converting any URIs with IP addrs as the
hostname component to resolved the resolved hostname via DNS, but we should already know that
relying on rDNS to be properly configured is a shot in the dark at best.

This message was sent by Atlassian JIRA

View raw message