accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bob Thorman (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2946) refactor namespace / table operations code to share more code
Date Mon, 11 May 2015 21:01:00 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2946?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14538639#comment-14538639
] 

Bob Thorman commented on ACCUMULO-2946:
---------------------------------------

Thanks Adam.  This help a lot and I think the idea of moving to concrete
classes is the simplest approach.  I may work that up and submit for a
review.  Appreciate the rewind.

v/r
Bob Thorman
Principal Big Data Engineer
AT&T Big Data CoE
2900 W. Plano Parkway
Plano, TX 75075
972-658-1714










> refactor namespace / table operations code to share more code
> -------------------------------------------------------------
>
>                 Key: ACCUMULO-2946
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2946
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: client
>            Reporter: Adam Fuchs
>            Assignee: Adam Fuchs
>            Priority: Trivial
>             Fix For: 1.8.0
>
>
> o.a.a.core.client.impl.NamespaceOperationsHelper and o.a.a.core.client.impl.TableOperationsHelper
have a lot of repeated code between them. Refactor them to remove the duplication. Maybe this
could be done by adding a boolean to the method signatures, representing whether we're configuring
a namespace or a table?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message