accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2946) refactor namespace / table operations code to share more code
Date Tue, 05 May 2015 16:59:00 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2946?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14528792#comment-14528792
] 

Josh Elser commented on ACCUMULO-2946:
--------------------------------------

I think efforts would be best directed to trying to collapse o.a.a.core.client.admin.NamespaceOperationsHelper
and o.a.a.core.client.admin.TableOperationsHelper as Adam originally said. Since they're both
implementing a public API interface (TableOperations), it sounds like a CommonOperationHelper
would be a good internal addition to consolidate things across the two implementations of
TableOperations.

Thanks for volunteering.

> refactor namespace / table operations code to share more code
> -------------------------------------------------------------
>
>                 Key: ACCUMULO-2946
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2946
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: client
>            Reporter: Adam Fuchs
>            Assignee: Bob Thorman
>            Priority: Trivial
>             Fix For: 1.8.0
>
>
> o.a.a.core.client.admin.NamespaceOperationsHelper and o.a.a.core.client.admin.TableOperationsHelper
have a lot of repeated code between them. Refactor them to remove the duplication. Maybe this
could be done by adding a boolean to the method signatures, representing whether we're configuring
a namespace or a table?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message