accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bob Thorman (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-2946) refactor namespace / table operations code to share more code
Date Tue, 05 May 2015 16:50:00 GMT


Bob Thorman commented on ACCUMULO-2946:

These two classes have two different interfaces, o.a.a.core.client.admin.TableOperations and
o.a.a.core.client.admin.NamespaceOeprations with a lot of relative documentation.  

First thought: do you see collapsing the common methods into generic ones with <table>
or <namespace> parameters?  This may require the addition of a third interface that
holds the generics and the original interfaces having those specific to their scope.  

Second thought: should a CommonOperationHelper class hold those methods that are needed by
o.a.a.core.client.admin.NamespaceOperationsHelper and o.a.a.core.client.admin.TableOperationsHelper
and use the boolean flag to set the scope as table or namespace respectively?

I would mind work this issue with some guidance.  Feel free to assign it to me and provide
some implementation details.  

> refactor namespace / table operations code to share more code
> -------------------------------------------------------------
>                 Key: ACCUMULO-2946
>                 URL:
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: client
>            Reporter: Adam Fuchs
>            Priority: Trivial
>             Fix For: 1.8.0
> o.a.a.core.client.admin.NamespaceOperationsHelper and o.a.a.core.client.admin.TableOperationsHelper
have a lot of repeated code between them. Refactor them to remove the duplication. Maybe this
could be done by adding a boolean to the method signatures, representing whether we're configuring
a namespace or a table?

This message was sent by Atlassian JIRA

View raw message