accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2946) refactor namespace / table operations code to share more code
Date Thu, 07 May 2015 17:47:00 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2946?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14533072#comment-14533072
] 

Christopher Tubbs commented on ACCUMULO-2946:
---------------------------------------------

I don't know that too much effort should be put into collapsing these, as the benefits will
be short-lived. I intend to deprecate the TableOperations and NamespaceOperations in the new
client API (ACCUMULO-2589). This is not an objection. I just don't want anybody to feel like
they've wasted their time. A refactor would still be beneficial (and appreciated), it's just
that its benefits might be limited in the long-term.

> refactor namespace / table operations code to share more code
> -------------------------------------------------------------
>
>                 Key: ACCUMULO-2946
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2946
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: client
>            Reporter: Adam Fuchs
>            Assignee: Bob Thorman
>            Priority: Trivial
>             Fix For: 1.8.0
>
>
> o.a.a.core.client.admin.NamespaceOperationsHelper and o.a.a.core.client.admin.TableOperationsHelper
have a lot of repeated code between them. Refactor them to remove the duplication. Maybe this
could be done by adding a boolean to the method signatures, representing whether we're configuring
a namespace or a table?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message