accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (ACCUMULO-2687) MiniAccumuloClusterImpl's getFileSystem only works if useMiniDFS = true
Date Fri, 29 May 2015 17:50:20 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-2687?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Christopher Tubbs resolved ACCUMULO-2687.
-----------------------------------------

I ran a quick test which extended AccumuloClusterIT and was unable to reproduce this problem.

I tried both {{cfg.useMiniDFS(true)}} and {{cfg.useMiniDFS(false)}}, I was able to successfully
verify that {{getCluster()}} returned an instance of {{MiniAccumuloClusterImpl}} and that
{{getCluster().getFileSystem()}} returned {{DistributedFileSystem}} and {{LocalFileSystem}}
respectively.

> MiniAccumuloClusterImpl's getFileSystem only works if useMiniDFS = true
> -----------------------------------------------------------------------
>
>                 Key: ACCUMULO-2687
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2687
>             Project: Accumulo
>          Issue Type: Bug
>          Components: mini, test
>    Affects Versions: 1.6.0
>            Reporter: Sean Busbey
>            Priority: Critical
>
> If you attempt to call getFileSystem on a MACImpl instance that is not using miniDFS,
it throws with a URL parsing error.
> Ran into this while attempting to work on an integration test, since by default ConfigurableMacIT
does not use the miniDFS.
> We should be able to return an appropriate local filesystem. Current workaround is to
override the configuration method and configure things to use minidfs.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message