accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Elser (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-3736) Underscore in password causes problems
Date Thu, 16 Apr 2015 17:21:59 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-3736?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14498334#comment-14498334
] 

Josh Elser commented on ACCUMULO-3736:
--------------------------------------

Ok, I thought it might be possible to get an underscore that wasn't an underscore too. Thanks.

> Underscore in password causes problems
> --------------------------------------
>
>                 Key: ACCUMULO-3736
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-3736
>             Project: Accumulo
>          Issue Type: Bug
>            Reporter: Christopher Tubbs
>
> A user reported that they were unable to authenticate to Accumulo (1.4.x) after setting
a password which contained an underscore.
> Steps the user performed:
> # Create new user in the shell using root
> # Set password, containing underscore on this new user
> # Switch to that user in the shell, it worked
> # Log in to the shell directly, using "-p" on the shell's command-line did not work
> # Using the Java API did not work
> The failure was "BAD_CREDENTIALS".
> I suspect he experienced some strange platform encoding issue with how we serialize passwords
to byte arrays internally, but this needs further verification (especially to check to see
if it applies to more recent versions).



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message