accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2131) while statement used as if statement
Date Thu, 09 Apr 2015 22:56:12 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2131?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14488439#comment-14488439
] 

Christopher Tubbs commented on ACCUMULO-2131:
---------------------------------------------

Well, I still disagree that it is substantively different. The idea that it undermines their
contribution I think is incorrectly inferred on insufficient information.

However, I will concede that my comment which accompanied my patch was insufficient, and I
should have clarified that it was being attached *solely* as a convenience for me to request
Keith (whom I consider an expert on this code) to review and compare which approach should
be applied. The fact that it was a patch instead of pseudo-code was simply because the change
was trivial for me to create as a patch, for him to review.

In the future, I will make more of an effort to explicitly anticipate somebody misconstruing
my intentions as stepping on people's toes, and will expend more time and effort to provide
sufficient detail in my comments so that the occurrence of such misunderstandings will be
(hopefully) less probable. In exchange, I politely request that others take greater efforts
to not jump to the conclusion that I'm ignoring or undermining somebody else's efforts, on
incomplete information. (In other words, please ["assume good intentions"|https://www.apache.org/foundation/policies/conduct.html#specific-guidelines].)

> while statement used as if statement
> ------------------------------------
>
>                 Key: ACCUMULO-2131
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2131
>             Project: Accumulo
>          Issue Type: Bug
>          Components: tserver
>            Reporter: Eric Newton
>            Assignee: Bob Thorman
>            Priority: Trivial
>              Labels: newbie
>             Fix For: 1.7.0
>
>         Attachments: 0001-ACCUMULO-2131-Ensure-source-is-re-checked-for-being-.patch,
ACCUMULO-2131.patch
>
>          Time Spent: 10m
>  Remaining Estimate: 0h
>
> Going through PMD output, and this looks a little sketchy in SourceSwitchingIterator.java:
> {noformat}
>   private boolean switchSource() throws IOException {
>     while (!source.isCurrent()) {
>       source = source.getNewDataSource();
>       iter = source.iterator();
>       if (iflag != null)
>         ((InterruptibleIterator) iter).setInterruptFlag(iflag);
>       
>       return true;
>     }
>     
>     return false;
>   }
> {noformat}
> I'm wondering if that "while" should be "if"



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message