accumulo-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Tubbs (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-2131) while statement used as if statement
Date Thu, 09 Apr 2015 22:18:12 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-2131?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14488394#comment-14488394
] 

Christopher Tubbs commented on ACCUMULO-2131:
---------------------------------------------

bq. Yes, but it's very inappropriate attach a patch when someone else is working on it and
hasn't asked for help.

I think I disagree with this pretty strongly. Anybody can provide more information on an issue
at any time, and they should be encouraged to do so. I think this is true, regardless of whether
it is a comment or an attached file (perhaps a diagram, a design document, a stack trace,
or as in this case, code).

Attaching additional information, and even code, does not obligate the code to be used, nor
should it be interpreted to supercede any other patches or code which has been attached to
the issue. It does not replace or invalidate the other work done, or convey any intention
that the previous work will be ignored.

> while statement used as if statement
> ------------------------------------
>
>                 Key: ACCUMULO-2131
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-2131
>             Project: Accumulo
>          Issue Type: Bug
>          Components: tserver
>            Reporter: Eric Newton
>            Assignee: Bob Thorman
>            Priority: Trivial
>              Labels: newbie
>             Fix For: 1.7.0
>
>         Attachments: 0001-ACCUMULO-2131-Ensure-source-is-re-checked-for-being-.patch,
ACCUMULO-2131.patch
>
>          Time Spent: 10m
>  Remaining Estimate: 0h
>
> Going through PMD output, and this looks a little sketchy in SourceSwitchingIterator.java:
> {noformat}
>   private boolean switchSource() throws IOException {
>     while (!source.isCurrent()) {
>       source = source.getNewDataSource();
>       iter = source.iterator();
>       if (iflag != null)
>         ((InterruptibleIterator) iter).setInterruptFlag(iflag);
>       
>       return true;
>     }
>     
>     return false;
>   }
> {noformat}
> I'm wondering if that "while" should be "if"



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message